MoDaCo.pl

Pełna wersja: Nvidia Shield - problem z flashowaniem
Aktualnie przeglądasz uproszczoną wersję forum. Kliknij tutaj, by zobaczyć wersję z pełnym formatowaniem.
Witam!
Mam problem ze sflashowaniem systemu za pomocą fastboota. Kernel, recovery flashują się bez problemu, ale system.img wywala błąd pod koniec.

Cytat:C:\adb>fastboot flash system system.img
target reported max download size of 570425344 bytes
erasing 'system'...
OKAY [  0.716s]
sending sparse 'system' (545106 KB)...
OKAY [ 25.135s]
writing 'system'...
OKAY [ 17.353s]
sending sparse 'system' (552714 KB)...
OKAY [ 25.773s]
writing 'system'...
OKAY [ 16.776s]
sending sparse 'system' (118407 KB)...
OKAY [  5.606s]
writing 'system'...
FAILED (remote: (InvalidSize))
finished. total time: 95.316s


co oznacza to InvalidSize? za duży obraz?
Dzięki z góry za odpowiedź
Tak na "chłopski rozum" i w tłumaczeniu bezpośrednim oznacza to "nieprawidłowy rozmiar/wielkość". Co ciekawsze, ten ... hmmm... rozmiar wcale nie musi być za duży. Nie wiem jak "skonstruowana" jest nV Shield, ale nie wykluczam, że komunikat może dotyczyć również zbyt małego rozmiaru. Trudno też powiedzieć czy komunikat dotyczy stricte obrazu, którym romujesz urządzenie. Jeśli pochodzi on (obraz) z zaufanego źródła i w żaden sposób nie jest modyfikowany to, przynajmniej teoretycznie, powinien być on prawidłowy. Jest i taka możliwość, że w pliku obrazu bądź w jakiejś części jego zawartości brakuje kilku(nastu) kilobajtów... o ile chodzi tutaj o jakieś nieprawidłowości z rozmiarem obrazu.
Ale to tylko takie gdybanie. Tutaj jest potrzebny ktoś mający pojęcie o romowaniu Shielda. Smile
Angielski znam, wiem co znaczy określenie InvalidSize Smile po prostu miałem nadzieję, że nie jestem pierwszą osobą, która się z tym błędem zetknęła i ktoś wie coś więcej na temat tego błędu Big Grin
Chyba ciężko żeby był za mały, bo takie rzeczy jak kernel, czy recovery flashowane były bez problemu Smile A obraz pochodzi z oficjalnych serwerów nvidii więc raczej zaufane. Pobierałem też kilka razy i za żadnym razem nie działało. Zmiana kompa też nic nie dała.
to w jaki sposób udostępnił to producent ? tzn w jakiej postaci ?
Nie jestem pewien, ale chyba to jest .zip pobierany przez OTA. Tyle, że byłem na jakimś CM12 więc w OTA nie moglem się bawić Smile
I już sobie poradziłem, flashując całego zipa sideloadem Smile
brawo Ty Big Grin
Jestem vice-mistrz yoda kappa

Zostawię notkę dla potomnych:
Okazało się, że jestem kompletnym debilem i instalowałem firmware na inną wersję urządzenia Big Grin
Pozdrawiam Smile
oj tam oj, bywa i tak. dobrze ze nie ucegliłeś urządzenia Big Grin